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Overview

This document describes how to install, configure and use a basic Avid software-
only Media Composer or NewsCutter editing system for MediaGrid edit-in-place 
for isolated or collaborative editing. In this scenario MediaGrid is used as shared 
storage and content can be stored in shared or private folders based on read/
write permissions.

Import and export with Omneon ConformTool, Marquis Medway and Avid Transfer 
Manager are not described in this document.
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1	A vid NewsCutter and Media Composer

NewsCutter and Media Composer are two editing systems offered by Avid that are similar in functionality and look and feel. NewsCutter is 
specifically designed for broadcast news operations whereas Media Composer is designed and used for promo, program, commercial, and 
film editing and used extensively outside of broadcast. MediaGrid supports edit-in-place with either application and Omneon testing has 
found no fundamental difference in the behavior or set up between either of these Avid applications.

Both Media Composer and NewsCutter can run on Windows platforms, and Media Composer can also run on OS-X. This document 
only covers Windows platforms.

Avid editing systems like NewsCutter and Media Composer can be part of a larger architecture that enables Media Asset 
Management and collaborative workflows. This architecture, called Interplay, is outside of the scope of this document.

In addition, NewsCutter and Media Composer can use external hardware modules for video i/o and compression/decompression 
such as Avid Mojo and Avid Adrenaline. These codecs also fall outside of the scope of this document. In other words, in this 
document the editing system hardware is limited to the PC that the editing software is running on.

Note: Omneon has done preliminary testing with Avid systems that do use Mojo or Adrenaline and results are positive. For these systems, 

and for systems with other external devices, Avid recommends using an Ethernet card instead of the on-board network interface (NIC) to 

connect to the network. See the References. Avid recommends the Alacritech and Intel Ethernet cards. The Alacritech card is qualified for 

more platforms than the Intel card, but the Intel card is more affordable. The Intel card is qualified for the xw8400 but when tested with a 

customer’s 8200 it worked fine. The Intel card model is Intel PRO/1000 MT PCI-X Dual-Port Gigabit Ethernet Adapter.

2	I nstallation

2.1	 Pre-requisites
In order to install the NewsCutter or Media Composer software, only a few things are needed: a PC, the software, and a license in 
the form of a dongle. The latest QuickTime and Windows Media Player need to be installed as well but these can be downloaded 
from the internet.

2.1.1	 Windows PC Hardware
In terms of the PC hardware, Avid provides minimum system requirements for hardware platforms (http://www.avid.com/products/
NewsCutter-Software/system-requirements.asp, http://www.avid.com/products/Media-Composer-Software/system-requirements.asp) 
and also recommends certain vendors and models. Of course the faster the PC the better. Avid’s minimum specifications are (from 
their Website):

Supported operating systems 

Processors

System Memory 
 
 

Graphics Card 
 

Internal Hard Drive 

Optical Drive

XP Professional SP2 (32 bit) 
Vista Business SP1 (32 or 64 bit)

Intel Core 2 Duo 2.33 GHz

2GB of RAM 
Note 1: If working with complex sequences, (multiple effects/streams) or compressed HD resolutions 4 GB of 
RAM is recommended. 
Note 2: Vista requires 4 GB of RAM

NVidia Quadro FX 560 or higher 
Note 1: Only Nvidia cards are supported 
Note 2: Full Screen play feature requires a minimum of 128MB of graphics memory

40GB minimum hard disk drive 
Note 1: Any media drives need to be 7200RPM or greater

DVD capable drive required for product installation

The user is free to try other choices but Avid only supports platforms that they have officially qualified. Our experience is that using 
platforms other than those recommended by Avid usually does not pose any problems.



2.1.2	S oftware
In addition to the Avid software, QuickTime and Windows Media Player need to be installed. The software can be downloaded from 
the internet. The examples in this document use QuickTime and QuickTime Player Version 7.4.5 and Windows Media Player 10.

The Avid software comes on a DVD or can be downloaded from the Avid Website if you have a support contract. The latest released 
software is always available on the Website. The Media Composer examples in this document are based on Media Composer version 2.8.

2.1.3	L icense
The Avid license comes in the form of a USB dongle that needs to be inserted into a USB port on the PC in order for NewsCutter or 
Media Composer to launch. 

Should it be necessary to upgrade the dongle, for instance with additional options, then a Dongle Manager can be downloaded from 
the avid web site at www.avid.com/dongle. 

The Dongle Manager is used to scan the existing license information on the dongle; it saves it in a text file in the same location as 
the Dongle Manager executable. Avid needs this file in order to generate the new one. Put the new file provided by Avid in the same 
directory as the executable and select it when using the Dongle Manager to blast the dongle with the new license.

2.2	 Pre-installation: Accounts and Media Players
Before installing the Avid software it is worthwhile to create one or more accounts with administrative rights for the Avid users. Log 
in as an Avid user.

Note: ConformTool and Marquis Medway, should either of these be installed (not covered in this document), also both need an 

administrative account but you can use the same ones as for the Avid users.

Next, install QuickTime Player and Windows Media Player. The software can be downloaded for free from the internet.

2.3	I nstallation: Avid software
After installing QuickTime and Windows Media Player, launch the Avid installer and a splash screen is displayed that lets you select 
several options. Choose the option that automatically installs all components. This will install not only the editing software but also 
several tools. Each is installed with its own splash screen and/or install wizard and the individual installers are launched automatically 
in sequence.

2.4	 Post-installation: MediaGrid File System Driver
As the final installation step, install the MediaGrid Windows File System Driver. The file system driver is the client portion of the 
MediaGrid file system.

Content is stored on the MediaGrid in slices, and to optimize edit application performance – uninterrupted playback of timelines and 
smooth scrub performance – the MediaGrid file system allows slice sizes ranging from ¼ Megabyte to 8 Megabytes. The size of the 
slices is configured on the MediaGrid.

The file system driver on the edit station has adjustable read ahead and read behind (random save) cache settings and they can be 
changed with the “Omneon MediaGrid” applet in the Windows Control Panel. Appropriate settings for the formats that were tested 
are shown in Section 3.3, including content slice sizes.

The file system driver runs as a service on the edit station and other than configuring the cache settings there is no direct user 
interaction. The user does need to mount the MediaGrid as a drive letter on the edit station, but after that all traffic to and from the 
MediaGrid is automatically routed through the file system driver service.
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3	 Configuration

3.1	 Mounting the MediaGrid
General practice would be to give each session its own directory and to have each Avid editor mount its own directory within the 
MediaGrid. This will allow that editor to be editing with their own private content if desired. The directory on the MediaGrid used in 
this document is called MEDIACOMPOSER1. If content is to be shared across multiple edit stations, then you will want to ingest 
content into a separate directory that all edit stations can have read permission to.

To mount a MediaGrid directory, add the path to that directory after the file system name.

Screen capture showing how to mount the MediaGrid directory MEDIACOMPOSER1 on the PC as drive letter M.  
(Only the first letter of the directory name is visible in the capture.)

The result of this mapping is shown in Windows Explorer screen capture below.

Windows Explorer showing directory MEDIACOMPOSER1 mounted as drive letter M.



3.2	L aunch Editor
Launch the editor and you will be presented with a dialog box that lets you select an existing project or create a new one. To create 
a new one, simply click the “New Project” button and enter the title of the new project. A new project will automatically be created 
that uses the same resolution and frame rate as the previous project.

To create a new project with a different resolution and/or frame rate, hold the Alt key when clicking the “New Project” button. This 
will enable a drop down menu in the New Project dialog box that would otherwise not be there.

The resolution and frame rate used throughout this document is 720p at 59.94 frames per second.

Screen capture showing the resolution and frame rate selection drop-down menu.

3.3	S elect File Wrapper Type and Video Format
Testing of Avid Edit-In-Place with MediaGrid has included in-house and customer testing. The formats tested, including MediaGrid 
slice size and Windows file system driver settings (MediaGrid 2.1 SR2), are shown below.

DV 50/IMX 50 29.97

SD 1:1/DNxHD 185

DVCPro HD 720p 59.94

Format
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Slice Size (MB) Read Ahead Random Save

The video format and type of file wrapper need to be selected in the NLE and this is done through the Media Creation settings in 
the Settings tab of the project window. Select the Settings tab, scroll down to Media Creation and double-click it to open the Media 
Creation window. Select the last tab Media Type and select OMF or MXF from the drop down menu as desired.

OMF stands for Open Media Framework and it was originally designed as a platform-independent file format for transfer of digital 
media between different software applications. Avid is moving away from full OMF support and high definition formats such as 720p 
can only be used with MXF.



C o n f i g u r at i o n  G u i d e l i n e s

After selecting and confirming the wrapper type in the Media Type tab, select the codec in the Import tab. The screen capture below 
shows the options available for the 720p project used in the examples.

The codecs available for MXF wrapped 720p.

For both wrapper type and video codec there is an “Apply to all” button that automatically selects the same choice in all tabs in the 
Media Creation window.

Finally, hit “OK” to exit the Media Creation window.

3.4	R ecognizing the MediaGrid
The editing system needs to be able to recognize the MediaGrid. Go to Tools > Console or hit [Ctrl+6] to open the command line 
console. In the command line box, enter “alldrives 1” and hit enter. The console will respond saying all drives will be viewed as 
media drives.

Entering “alldrives 1” in the Console allows the editing system to use MediaGrid as media storage.



Next, re-open the Media Creation window and select the Import tab. In the drive letter drop down menu for the video and audio 
drives, select the letter used by the MediaGrid. Press “Apply to All” to make this setting take for all tabs.

Selecting the MediaGrid (letter M:) as the location for the media. Be aware that letter M: points to directory MEDIA COMPOSER1.

3.5	 Create Directory Structure
NewsCutter/Media Composer expect a certain directory structure for storage of media, which in this case is on the MediaGrid. The 
structure can be created manually but it is easier to have the editing application create it by itself. Having the application do it is 
also less prone to errors.

One easy way to have the application create a directory structure is by creating and saving a title. Go to Tools > Title Tool and select 
Title Tool. Click in the title tool window and enter a title. Next, go to File > Save Title as… and enter a Title Name. Make sure the 
title will be saved on the MediaGrid (check the drive letter) and hit “Save”.

Creating and saving a title to create a directory structure
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After saving the title it will show up as an item in the project bin. The new directory structure created by the application for MXF is 
shown below. The structure and files will be different for OMF.

Windows Explorer showing the newly created structure and files on the MediaGrid

At this point the system is ready for editing. Media can be loaded in the normal ways available including importing QuickTime-wrapped 
media from MediaGrid e.g. with Medway, file transfers from other edit workstations, baseband capture to MediaGrid through Avid Mojo 
(see the note in Section 1.1) etc.

4	 Media Composer System Specification

Below is the system specification for the MediaComposer used in the tests.

Workstation model

CPU model and speed

RAM

Graphics card

Hard drive

Operating System

QuickTime and QuickTime Player

Windows Media Player

Avid Media Composer

WinFSD version

Hewlett-Packard HP xw6600 Workstation

Dual-quad Intel Xeon CPU E5440 @ 1.98 GHz

4GB but 3.25 GB recognized by Windows XP Pro 32

Diamond Viper (ATI) X1950 Pro, 512 MB RAM

Western Digital Caviar RE2, SATA, 400 GB

Windows XP Pro 32-bit, Version 2002, Service Pack 2

Version 7.4.5

Version 10

Version 2.8

2.1.200805.21

5	R eferences

The documents listed below are available in the Avid Knowledge Base on the Web by searching for keywords “Configuration Guidelines”.

1:	 “Avid Configuration Guidelines Media Composer HP xw4600 Core 2 Duo Workstation”, by Avid. 
2:	 “Avid Adrenalline and Avid Mojo Configuration Guidelines for the HP xw8000 Workstation”, by Avid. 
3:	 “Avid Xpress Pro and Avid Adrenaline Configuration Guidelines HP xw8200 Workstation”, by Avid. 
4:	 “Avid Configuration Guidelines HP xw8400 Workstation”, by Avid. 
5:	 “Avid Configuration Guidelines HP xw8400 Dual Quad-Core Workstation (For use in software only environments)”, by Avid. 
6:	 “Avid Configuration Guidelines Media Composer HP xw8600 Dual Quad-Core Workstation”, by Avid.


