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Overview

This document describes conditions, setup, and procedures for creating a networked
editing environment composed of an Omneon MEDIADIRECTOR and one or more
Macintosh computers running Apple Final Cut Pro (FCP).

NOTE: Omneon uses the term, Edit-in-Place (EIP), when referring to a production
configuration where video and audio essence (footage) are stored on the Omneon
server while the FCP workstations use these essence without moving them to
local (workstation) drives.

The FCP software application determines the reliability of workstation playback of
footage placed on an editing sequence timeline or for a clip. A playback condition,
known as “dropped frames”, may occur when the application is unable to produce
the requisite frame order. The clip or timeline playout may stutter, or skip one or
more frames, or stop.

The FCP interface provides a User Preference setting that addresses dropped
frame events. To display the User Preference window, click the User Preference
option in the Final Cut Pro Application menu. In the General pane of the window,
toggle a checkmark on or off for the “Report dropped frames during playback”
selection. When a checkmark is present, FCP will stop the timeline playout and
display an information message describing the event. When a checkmark is not
present and a dropped frame event occurs, FCP will continue the playout but the
dropped frame event will result in a momentary video stutter, skip, or still frame.
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Equipment and Networking Requirements

The speed of Macintosh computers directly impacts Edit-in-Place performance. Faster computers can read video data without dropping
frames. While Omneon has not set EIP performance specifications for Macintosh workstations running FCR dual-CPU machines drop
fewer frames during viewing than single-CPU models. Using G5 dual-CPU 2.0 GHz (or better) mini towers with 1GB of memory (or more)
is recommended.

Note the following when installing an FCP/Omneon EIP environment:

Macintosh computers must be networked with an Omneon MCP 2101 or an MCP 2100 MEDIADIRECTOR using Gigabit Ethernet
(1000 Mbps). The best networking performance is achieved using a Gigabit Ethernet (GigE) switch, such as the Netgear GS508T.

Isolate Ethernet connections to the Macintosh workstations from realtime MEDIAPORT traffic by using separate host processors
on the MEDIADIRECTORS.

Configuration Guidelines for Edit-In-Place with Final Cut Pro

A file can be exported from Final Cut Pro to the server either as a “self-contained” movie or as a “reference” movie. Either approach
can be used to create a QuickTime file in the “.mov” file format. From the FCP File menu, click Export > QuickTime Movie to display
the Save window and to specify the file export type.

A self-contained movie is a monolithic clip that contains all of the essence for a clip or a sequence. Whether the essences are resident
on a local workstation drive or on the server, when a file is exported as a self-contained movie, Final Cut Pro creates a self-sufficient
clip using the render tools of the application.

With a reference movie, FCP generates a file that points to the various clip or sequence essences, much like an EDL (Edit Decision
List). When present, only those elements that require rendering, such as a transition or more than two audio tracks, will be rendered
for inclusion in the reference movie file. This method is faster than the self-contained movie process as reference files are small and
may be exported for play-to-air very quickly if essence files already reside on the server.

Omneon release 4.2 SR2 (and later) supports the following

Final Cut Pro version 3.0.2 (or later), running on OS X version 10.2.3 (or later) with QuickTime version 6.1 (or later).

EIP configurations with up to four FCP workstations per MEDIADIRECTOR host processor performing DV or DVCPRO25 format
editing of timeline content composed of cuts and/or dissolves, with 2 audio tracks. Or, EIP configurations with up to three FCP
workstations per MEDIADIRECTOR host processor performing DVCPRO50 format editing of timeline content composed of cuts
and a small number of dissolves per minute, with 2 audio tracks. These EIP configurations are only supported when utilizing a
dedicated FCP/Omneon MEDIADIRECTOR host processor port connected via Gigabit Ethernet.

Omneon recognizes that within the EIP configurations mentioned above, FCP dropped frame events may occur. Your perception of
acceptable rates of dropped frames during editing will determine your total FCP workstation count.

Exporting self-contained movies from FCP to the server as a QuickTime “.mov” file.

Exporting reference movies from FCP to the server as a QuickTime “.mov” file.

Omneon does not support the following procedures or conditions

FCP cannot be used to directly capture footage from a source device to a mounted Omneon server.
The FCP timeline cannot be played directly to air through a workstation realtime video card, when essence are resident on the server.
The Omneon server in a Final Cut Pro configuration does not support DVCPRO HD format material.

A single host processor in an Omneon MCP 2101 MEDIADIRECTOR is not supported for the purposes of integrating FCP workstations
to the network and for playing files directly to air. The FCP environment must be segregated from play-to-air operations.



Configuring the Omneon Server for Edit-in-Place

Edit-in-place maintains footage residency on the Omneon server. Using Omneon Recorder/Players, footage is captured to the server
prior to editing with Final Cut Pro. Server players must be configured with:

one DV video track, and

one 16bit, “.aiff” 2-channel audio track

When creating the recorder/player, set the DV (DVCPRO 25, DVCPRO 50) video track type according to the footage format of the material that
will be edited with FCP Refer to the latest version of the Omneon Spectrum System User’s Guide for instructions on creating Players for record.

When editing with FCR on occasion, you may need to render an element on the timeline. To maintain the Edit-in-place configuration,
save the rendered elements to the Omneon server. Use the System Settings command in the FCP Application menu to display the
System Settings window as shown in the following figure.
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Figure 1. FCP System Setting Window

Set the Scratch Disks destinations for Video Render and Audio Render so that FCP rendered elements are saved to the server.
Deselect local workstation destinations for these elements, to avoid confusion and duplication. Use the Apple Finder utility to
establish and name the destination folders on the server.

File Handling for Edit-in-Place and Final Cut Pro

Files generated by Final Cut Pro do not follow Omneon’s file naming schemes, so the MEDIADIRECTOR has been given special rules
that write FCP’s output to allow edited clips to play out correctly on an Omneon SPECTRUM System. Omneon ships MCP 2101
MEDIADIRECTORS preconfigured for FCP configured installations, however you must create an FCP directory on the MEDIADIRECTOR
before these rules can be accessed.

These rules are sufficient for most FCP users as long as all Final Cut Pro movies are exported to the “FCP” directory on the Omneon file
system with the “.mov” extension. For the files to be playable by the server, they must end with “.mov” in order to appear as Omneon clips.

Footage captured directly to the server using an Omneon Recorder/Player is saved within a folder named, “clip.dir”, and appears as “.mov”
files listed in the “clip.dir” folder. The “.mov” files point to the “.dv” and “.aiff” essence which are stored in a subfolder named, “media.dir”.

To maintain an Edit-in-Place configuration, the user should only import the “.mov” files for the footage. The import is near instantaneous
as the essence remain on the server while the pointer file is imported to the workstation.
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Connecting a Macintosh to the Omneon Server via AFP

Each Macintosh workstation uses an ethernet connection for accessing the Omneon server. Prior to launching Final Cut Pro, the
Omneon server must be mounted on the network using Apple File Protocol (AFP).

Mount the Omneon file system using Apple File Protocol as follows:

1 Select Apple Finder Menu > Go > Connect to Server, the Connect to Server dialog appears. You can also use the shortcut
keys, [Command][K], to display the dialog.

eann Connect To Server
Server Address:

afpr 0. XX XXX &

Favorite Servers:

(" Remove { Browse ) w

Figure 2. Connect to Server Window

2 In the Server Address field, type “afp://” followed by the IP address for the Host.

Refer to the MediaDirector Properties page on the MANAGER Application to determine the IP address for the specific
MEDIADIRECTOR Host.

3 Click Connect to display the Password dialog as shown in the figure following. In the Password dialog, click the Guest radio
button. (Do not use the Registered User option, even though you may note that a login name is initially displayed in the dialog.)

- Connect to the file server "Omneon
e MediaServer D2-01718H0" as:

@ Guest
_ Registered User

Options ( cancel ) m

Figure 3. Connect to File Server Dialog



4 Click Connect to display the file system window for the selected server. Note that the server and file system names are suffixed
with the host number. This is a useful check to make sure you are logging into the correct MEDIADIRECTOR Host.
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Figure 4. File System Window

5 Click OK to display the Omneon file system share on the workstation Desktop and in the Finder window for the workstation.

NOTE: We recommend you create an alias for the server share on the Desktop. Use the alias to avoid subsequent sessions of
the “Connect to Server” dialog whenever the Macintosh workstation is restarted. To create an alias, select the server icon on
the Desktop and then execute the Make Alias command in the Apple Finder File menu.

Importing Omneon ingested “.mov” files to a Final Cut Pro Project
Use the following procedure to import “.mov” files when working with FCP in an Edit-in-Place configuration.

1 Open an FCP project.

2 From the File menu, click Import > Files to display the Choose a File window as shown in the following figure.
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Figure 5. FCP’s Choose a File Window
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3 Navigate to the Omneon server folder that contains the “.mov” files for the captured footage.

4 Select the .mov files in the folder window.

Use [Shift]-click to select adjacent files, or use [Command]-click to select multiple non-adjacent files.

5 In the Choose a File window, click Choose to start importing the files.

The essence remains on the Omneon server, and the selected “.mov” files are added to the current project on the workstation.

Importing Omneon ingested footage files for a Final Cut Pro Project

When you need to relocate footage to the local workstation, “.mov” and associated files must be transferred from the server to local
folders. Once the files are relocated to the workstation, they can be imported to the current project.

Use the Finder utility of the Macintosh to perform footage transfer as follows:

1 Select the Finder icon on the Dock for the Macintosh to display the file system window.

2 Navigate to the local workstation folder that will be used to store the transferred “.mov” files. If needed, use the New Folder
item to generate the destination folder.

3 Select the New Finder Window command in the Apple Finder File menu to display a second file system window. Navigate to the
Omneon server share folder containing the “.mov” files for the footage being transferred.

4  Select the “.mov” files in the server folder window.

Use [Shift]-click to select adjacent files, or use [Command]-click to select multiple non-adjacent files.

5 Drag the selected “.mov” files from the server folder window to the workstation file system window and drop them in the
destination folder.

6 In the workstation folder, create a New folder named, “media.dir”. This folder will be used to store the asset files for the
associated “.mov” files. Double click the “media.dir” folder to update the window display to show the folder contents.

7 In the server file system window, display the “media.dir” folder contents for the transferred “.mov” files.
8 In the server “media.dir” folder, select the associated “.dv” and “.aiff” essence files for the “.mov” files.

9 Drag the selected essence files from the server file system window to the workstation file system window and drop in the
destination “media.dir” folder.

10 For the current FCP project, .from the File menu, click Import > Files to display the Choose a File window
11 Navigate to the local workstation folder that contains the “.mov” files for the relocated footage.

12 Select the “.mov” files in the file window.

Use [Shift]-click to select adjacent files, or use [Command]-click to select multiple non-adjacent files.

13 Click Choose in the Choose a File window to import the files. The selected files are added to the current project.



Exporting a Clip or Sequence from Final Cut Pro to the Omneon Server

Whether working in an Edit-in-Place configuration, or with the footage resident on the local workstation, the edited clip or timeline
sequence must be exported to the Omneon server for play-to-air, or for distribution to other networked FCP workstations.

Follow this procedure to perform an export:

1 From the FCP File menu, click Export > QuickTime Movie to display the Save window as shown in the following figure.

Save

Save As: EditProjectl.mov B

Where: @ fsO-HO F’e]

Setting: Current Settings
Include: Audio and Video
Markers: None

__ Recompress All Frames
" Make Movie Self-Contained

1))

Figure 6. FCP’s Save Window

2 Update the Save As field in the window with the desired file name and add the “.mov” extension following the name.

IMPORTANT: The “.mov” extension must appear with the file name so that the file data is saved in a playable format on the
server and is visible to an Omneon player.

3 Update the Where field in the window to reflect the desired destination for the file being exported.

4 Click the arrow buttons next to the field to navigate to the intended Omneon server share.

NOTE: Omneon recommends that you create an FCP directory on the Omneon media server to store exported FCP files. If
exporting to another directory, the fileypes.conf rules must be edited. See the user manual for further detail.

5 Toggle a checkmark on or off for Make Movie Self-Contained in the Save window. When a checkmark is present, the selected file
is exported to the Omneon server as a self-contained movie. When a checkmark is not present, the selected file is exported as
a reference movie.

Note the following important points:

When footage essence are resident on the local workstation, you can export the file as a self-contained movie. This will
insure that the exported file will play-to-air properly.

When footage essence have remained on the server using an Edit-in-Place configuration, you can export the file as a
reference movie. Omneon highly recommends that the clip or sequence be re-exported as a self-contained movie when time
permits. If an original clip used in a reference movie is deleted, subsequent file playout will be incorrect.

6 Click Save in the Save window to initiate the export process.

The exported file name appear in the destination folder of the Omneon server share when the export process is finished.
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Limitations when Using Final Cut Pro with Omneon Servers

FCP files saved into directories which are not pre-configured to accept them will not be playable because they will not be
recorded in the proper file stripe. They files may load into Players and the first frame may appear on a MEDIAPORT output, but
the video will not play properly.

FCP movies saved into the wrong directories (and thus saved in the wrong stripe) cannot be made playable by moving them into
the proper directory. The stripe type is determined at the time the file is saved to the server.

FCP movies that are saved without the “.mov” extension will not be playable, and will not be visible to the Omneon player
mechanism. Adding the .mov extension after the fact will make the file visible, but not playable because it will have been
recorded in the wrong stripe.

Dropped frames may occur during a timeline playback within the FCP application. Dropped frames on playback do not indicate
problems with the source file; play through the dropped frame area to verify that all of the frames do exist. Dropped frames are
only an issue when playing a timeline. An exported FCP movie, either self-contained or reference, will not contain any dropped
frames when all of the footage essence are resident on the Omneon server.

You will be unable to delete files from the Omneon server using a Macintosh Finder if the file is in use by another process. Files
currently loaded into FCP or into a QuickTime Player, for example, cannot be deleted.

Additionally, if you have the Finder set for column view and have the preview column enabled (with a Finder window selected,
View > Show View Options... > Show Preview column), you will not be able to delete a movie file. When you select a file, it
appears in an embedded QuickTime player in the preview column. To delete multiple movies select more than one for deletion.
To delete a single movie from the Finder you must first turn off the preview column feature.

Exporting via Ethernet currently has a clip length limitation due to Apple OS X. If you have a problem exporting a long clip you
should export to the local drive and use the Apple Finder utility to transfer files to the Omneon SPECTRUM System.
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